О программе Macros

SFX-Macros – утилита для быстрого написания универсальных скриптов, для автоматизации установки приложений. Готовый скрипт сохраняется как приложение (exe-файл). Основная задача, создание универсальных скриптов, то есть один и тот же скрипт должен подходить для разных ОС. Программа, ориентирована на IT-специалистов, несвязанных с программированием, но имеющих опыт работы с "командной строкой", т.к. в основном выполнение команд происходит по принципу cmd.exe /c "команда".

© 2014 Дмитрий Малгин Malgin-D-A@mail.ru

http://checkdevice.narod.ru/


Общие сведения

Возможности:

• Наличие встроенных команд, для наиболее часто используемых действий: копирование, удаление, запуск приложений и другие.

• Возможность запустить каждую команду скрипта отдельно, для проверки ее работы.

• Возможность контролировать результат выполнения каждой команды и возможность прервать выполнение скрипта, если одна из команд завершилась с ошибкой.

• Скрытое выполнение команд - запуск приложений или bat-ников в скрытом режиме.

• Задание свойств командам, для какой ОС предназначена команда.

• Запрос прав Администратора, все дочерние процессы автоматически получают права Администратора.

• Сохранение готового скрипта как новое самостоятельное приложение.

• Создание SFX-архивов.

Интерфейс:

Простой, интуитивно понятный интерфейс в виде таблицы.

Первая колонка «Команда» - непосредственно сама команда, выбирается из выпадающего списка.

Вторая и третья колонки, «Параметр 1» и «Параметр 2» - заполняются в зависимости от команды.

Если команда «Copy», то «Параметр 1» - это что копируем, а «Параметр 2» - это куда копируем.

Если команда «Start», то «Параметр 1» - это путь к приложению, а «Параметр 2» - это ключи запуска, подробнее в описании команд.

В колонке «ОС» указывается версия ОС для которой предназначена команда, по умолчанию для всех ОС (значение «All»).

В колонке «Тип» указывается разрядность ОС, по умолчанию для всех (значение «All»).

В последней колонке отображается результат выполнения.

Для наиболее часто используемых действий, есть встроенные команды: копирование, удаление, запуск приложений и другие.

Некоторые встроенные команды и специальные переменные не описаны в данной справке, т.к. они разработаны для конкретных организаций и работают исключительно в пределах локальной сети конкретной организации.


Команда FileExists

Сохранить как -> меняем тип файла на «*.exe»


Команды

Для наиболее часто используемых действий, есть встроенные команды: копирование, удаление, запуск приложений и другие.

Некоторые встроенные команды и специальные переменные не описаны в данной справке, т.к. они разработаны для конкретных организаций и работают исключительно в пределах локальной сети конкретной организации.


Команда CheckErrors

Команда «CheckErrors» - проверка ошибок.

Проверяет результат всех ранее выполненных команд, если хотя бы одна команда выполнена с ошибкой, то останавливает выполнение скрипта и открывает главное окно программы.

Для проверки «Предупреждений» нужно предварительно выполнить команду «CheckWarning».


Команда CheckWarning

Команда «CheckWarning» - проверка предупреждений.

Проверяет результат всех ранее выполненных команд, если хотя бы одна команда выполнена с предупреждением, то записывает в результат выполнения данной команды ошибку.

Подразумевается использование после данной команды, команды для проверки ошибок «CheckErrors» или «ExitCode».

Предупреждения, в качестве результата выполнения команды «Start» или «StartHide», возникают, если запускаемое приложение или консольная команда возвратила код ошибки.


Команда Clipboard

Команда «Clipboard» помещает в буфер обмена Windows значение указанное в «Параметр 1».


Команда Copy

Команда «Copy» копирует файл\папку, с заменой, если файл\папка уже существует.

«Параметр 1» - что копируем.

«Параметр 2» - куда копируем.


Команда CreateDir

Команда «CreateDir» создаёт папку.

«Параметр 1» - указывается путь к папке в месте с названием новой папки.

Создается вся структура папок.


Команда «CreateLink» создаёт ярлык.

«Параметр 1» - путь к ярлыку вместе с именем ярлыка и расширением, например C:\Ярлык.lnk.

«Параметр 2» - путь к приложению, для которого создаётся ярлык.


Команда Del

Команда «Del» удаляет файл\папку.

«Параметр 1» - указывается путь к файлу\папке.


Команда DelSelf

Команда «DelSelf» - само-удаление скрипта.

Не работает, если приложение (скрипт) запущено с сетевого диска.


Команда DesktWallp

Команда «DesktWallp» устанавливает картинку на рабочий стол.

«Параметр 1» - путь к картинке для рабочего стола.

«Параметр 2» - нужно указать значения от 0 до 3.

0 - "Посередине"

1 - "Рядом"

2 - "Растянуть"

3 - "Заполнение" – не поддерживается на WinXP


Команда ExitCode

Команда «ExitCode» - проверка ошибок.

Проверяет результат ранее выполненных команд, если хотя бы одна команда завершилась с ошибкой, то останавливает выполнение скрипта, завершает работу приложения (скрипта), возвращая код ошибки 1.

Для проверки «Предупреждений» нужно предварительно выполнить команду «CheckWarning».


Команда FileExists

Команда «ExtractFiles» распаковывает заранее упакованные в SFX-архив файлы.

«Параметр 1» - путь к папке, в которую будут распакованы файлы.

Для создания SFX-архива нужно предварительно подготовить файлы, собрав их в одной папке.

Главное меню -> SFX -> Добавить файлы из папки -> Выбираем папку

При сохранении скрипта в exe-формате, все файлы, вместе с под-папками, будут упакованы в исполняемый файл.


Команда FileExists

Команда «FileExists» проверяет наличие\отсутствие файла.

«Параметр 1» - путь к проверяемому файлу.

«Параметр 2» - «True» для проверки наличия файла, «False» для проверки отсутствия файла.


Команда Kill

Команда «Kill» - завершение процесса.

«Параметр 1» или «Параметр 2» - имя процесса который необходимо завершить.


Команда LoadString

Команда «LoadString» загружает значение в спец. переменную {String}.

"Параметр 1" - файл.

"Параметр 2" - строка.


Команда «LockProcess» блокирует запуск процесса.

«Параметр 1» - имя процесса, например browser.exe.

«Параметр 2» - нужно указать «True» для блокировки, или «False» для разблокировки.

ВАЖНО - не забывайте делать разблокировку, иначе приложение останется заблокированным!


Команда Pause

Команда «Pause» - временная пауза в выполнении скрипта.

«Параметр 1» - время задержки в секундах.

Если не указывать «Параметр 1», то появится кнопка "Установить", для продолжения выполнения команд нужно на нее нажать.

«Параметр 2» - заполняется, только если не указан «Параметр 1», в нём указывается сообщение для пользователя.

Так же можно в «Параметр 1» указать надпись для кнопки, например «Далее».


Команда «SelectFolder» - для ручного ввода данных, например для выбора папки, введённые данные присваиваются переменной {SelectFolder}.


Команда Title

Команда «Title» отображает окно с подробной информацией по текущей команде.

«Параметр 1» - название окна,

«Параметр 2» - сообщение в самом окне.

Если не использовать команду «Title», то выполнение скрипта будет в скрытом виде.


Команда FileExists

Ключи запуска:

/s - автоматическое выполнение, игнорируется диалог "Продолжить" (команда Pause без параметров)

/h - скрытый режим (игнорируется команда Title и диалоги "Продолжить")


Команда «CreateDir» создаёт папку.

«Параметр 1» - указывается путь к папке в месте с названием новой папки.

Создается вся структура папок.


Команда «DownloadFile» - для загрузки файла из интернета.

«Параметр 1» - прямая ссылка на файл.

«Параметр 2» - путь, куда сохранить (вместе с именем файла).

Если файл уже существует, то он сравнивается по размеру с файлом на сайте, если размер одинаковый, то загрузка пропускается.