MInstAll

  • MInstAll
MInstAll © 2015 Дмитрий Малгин
MInstAll - Мастер установки приложений, бесплатная утилита для автоматической (тихой) установки приложений и настройки системы. Упрощенный аналог WPI.
Возможности:
• Сортировка программ по группам
• Создание нескольких профилей
• Справочник ключей для разных типов инсталляторов
• Установка иконок из exe, dll, ico - файлов
• Сортировка последовательности групп и приложений
• Скрытый запуск приложений
• Два режима работы: "Установка" и "Редактирование"
• Блокировка режима редактора
• Авто запуск установки для профиля по умолчанию
• Функции Exclude и Include
• Спец. профиль для запуска портативных приложений
• Импорт reg-файлов
• Добавление приложений перетаскиванием из проводника Windows (файлового менеджера)
• Поддержка Unicode
• Проверка наличия уже установленных приложений
• Проверка результата установки через реестр и по наличию файла
• Перезагрузка ОС с последующим продолжением установки приложений
• Функция отключения "редиректа" на ОС 64-бит для исполняемых файлов: *.reg; *.cmd; *.bat
• Идентификация инсталлятора с целью определения ключей для "тихой" установки
Скачать История версий Форум
Системные требования:
Windows XP x86; Windows 7 x86/x64; Windows 8 x86/x64; Windows 8.1 x86/x64; Win Server 2008 R2; Win Server 2012; Win Server 2012 R2.

Содержание MInstAll

История версий
Ключи инсталляторов
Описание функций
FAQ
О ложных срабатываниях антивирусов


История версий

Версия: 1.0.1.63
• Добавлено удаление файлов дистрибутива через файловый менеджер.
• Исправлено обновление иконок-кнопок после редактирования и сортировки.
Версия: 1.0.1.62
• Разгружено контекстное меню (три пункта перенесено в главное меню).
• Проработан клик правой кнопкой мыши по пустому месту, по подгруппе, по "Выйти из программы установки", не актуальные для данных мест функции переходят в неактивное состояние.
• Исправлена функция "Заменить" (обновление иконок статуса, состояния и URL).
• Доработан запуск файлового менеджера с сетевого диска.
• Исправлена потеря "Выйти из программы установки" при создании нового профиля.
Версия: 1.0.1.61
• Добавлена кнопка запуска для всех приложений, для которых эта функция актуальна.
• Добавлены подсказки для иконок состояния.
• Добавлено открытие каталога с дистрибутивом через файловый менеджер, путь к файловому менеджеру и ключи запуска задаются в файле minst.ini параметры FMPath и FMKey. Для параметра FMKey доступны две дополнительные переменные {OpenPathFile} = путь к файлу или {OpenPathDir} = путь к каталогу.
Версия: 1.0.1.60
• Небольшие изменения в окне описания.
• Добавлено "таскание" окна описания за форму.
• Добавлены подсказки для статусных иконок.
• Добавлены кнопки-ссылки на URL, отображаются в режиме редактирования для всех приложений у которых задан URL.
• Добавлен переход в режим редактирования по нажатию Alt.
Версия: 1.0.1.59
• Добавлена поддержка URL ссылок, в портативный профиль, вместо приложения можно добавить URL ссылку. Через контекстное меню "Добавить подгруппу", в поле "Путь к приложению" указываем ссылку, ссылка должна начинаться с http:// или с https://
• Добавлен переход из состояния "Только чтение" в обычный режим при нажатии на замок.
• Добавлен переход в другой профиль (по ссылке, в не портативном профиле) при нажатии на Enter (из режима установки).
• Добавлено открытие окна с описанием (в не портативном профиле) при нажатии на Enter (из режима установки).
• Добавлено закрытие окна с описанием при нажатии Esc.
• Добавлена подсказка для процесса отмены, отображается красным цветом в строке состояния после нажатия на кнопку "Отменить".
• Исправлено позиционирование окна при увеличенной панели задач Windows.
Версия: 1.0.1.58
• Обновлен AutoRun.exe
Версия: 1.0.1.57
• Изменено копирование параметров, теперь через буфер обмена Windows.
Версия: 1.0.1.56
• Добавлена кнопка "Отсортировать в алфавитном порядке"
Версия: 1.0.1.55
• Добавлена новая опция, Главное меню -> Настройки -> "Не снимать выбор с установленных и несовместимых в режиме редактора"
Версия: 1.0.1.54
• Добавлена поддержка Windows 10 build 9926 (изменилась версия ядра с 6.4 на 10.0)
• Добавлены новые переменные для разрядности {P1} и {P2}
Версия: 1.0.1.53
• Исправлена ошибка, приводящая к невозможности выбрать иконку из dll-ки, возникающая при определенных условиях.
• Другие небольшие исправления.
• Добавлено отображение времени прошедшего с момента начала установки текущего приложения.
Версия: 1.0.1.52
• Добавлена функция для определения защиты от записи, авто-переход в режим ReadOnly при отсутствии доступа. Функция включается в Главном меню -> Настройки -> "Определять защиту от записи".
Версия: 1.0.1.51
• Добавлена авто-замена системной виртуальной папки sysnative на system32 если MInstAll запущен из 32-битной системы.
Версия: 1.0.1.50
• Для решения проблемы с не сохранением кавычек, если они стоят в начале и конце ключей запуска (проблема ini-формата), добавлена переменная {"}
Версия: 1.0.1.49
• Добавлена возможность удалить "Выйти из программы установки", опять добавить можно в свойствах профиля.
• Добавлена переменная {L} язык ОС.
• Добавлено окно с описанием внутренних переменных, Главное меню -> Справка -> Переменные.
Версия: 1.0.1.48
• Удалена ссылка на оф.сайт.
• Исправлена подсказка для кнопки "Отменить".
Версия: 1.0.1.47
• Добавлена переменная {winname} для использования в заголовке главного окна или в описании профиля.
Версия: 1.0.1.46
• Оптимизирована функция проверки наличия системных обновлений, активируется при первом обращении к ней, то есть если используете проверку для обновлений, то добавляйте обновления в начало списка приложений, что бы к моменту загрузки последнего она успевала выполнится. Если к моменту загрузки последнего приложения из списка, функция проверки системных обновлений еще не выполнилась, то будет ожидание, не пугайтесь это нормально, прогресс бар будет на 100% а в строке состояния будет соответствующая надпись "Проверка наличия системных обновлений ...".
• Добавлено отображение имени текущего процесса в строке состояния, то есть непосредственно имя процесса, завершение которого ожидает программа перед установкой следующего приложения.
• Добавлена переменная {winbuild} для использования в заголовке главного окна или в описании профиля.
Версия: 1.0.1.45
• Добавлена функция проверки наличия обновлений Windows, проверяются только системные обновления, проверка обновлений компонентов (Visual C++, NET Framework и т.п.) не предусмотрена. Для включения проверки нужно указать в поле GUID значение HotFixID а в поле версии указать Update. Узнать HotFixID установленных обновлений можно выполнив в командной строке "wmic qfe list".
• Добавлено автоматическое снятие атрибута "Только для чтения" для файлов профиля, при сохранении.
Версия: 1.0.1.44
• Добавлена переменная {v}, которая принимает значение версии операционной системы, например на Windows 8.1 переменная примет значение 6.3
Версия: 1.0.1.43
• Изменения в окне описания, добавлены: кнопка "Закрыть", статус программы; перенесена кнопка для изменения размера окна.
Версия: 1.0.1.42
• Изменено окно с описанием.
Версия: 1.0.1.41
• Добавлено три варианта размера шрифта: Мелкий, Средний, Крупный.
• Добавлена принудительная сортировка списка профилей по имени файла профиля.
• Добавлена индикация текущего (прошедшего) времени установки.
• Окно "Описание для профиля" переименовано в "Свойства профиля", добавлена настройка ширины колонки версии.
• Часть пунктов из контекстного меню перенесено в главное меню.
• В главное меню добавлены функции: "Свойства профиля", "Удалить профиль", "Выбрать приложения с отсутствующем дистрибутивом", "Сохранять профили в Unicode", "Заблокировать режим редактирования".
Версия: 1.0.1.40
• Добавлено главное меню, часть пунктов из контекстного меню перенесено в главное меню.
• Из главного меню "Деинсталлировать программу" будет запускаться Check Device, при условии его наличия по пути {Patch}\portable\chdevice\CheckDevice.exe
Версия: 1.0.1.39
• Добавлено лицензионное соглашение.
Версия: 1.0.1.38
• Добавлена возможность изменять цвет: подгруппы, версии, не совместимых.
Версия: 1.0.1.37
• Добавлена поддержка Windows 10.
Версия: 1.0.1.36
• Добавлена возможность выводить дополнительную информацию в заголовке главного окна программы, в файле настроек minst.ini параметр Caption.
• Добавлены новые переменные: {mver} и {winver}, которые можно использовать для отображения информации в заголовке главного окна и в описании профиля. Так же в заголовке и описании можно использовать переменную {p}.
{mver} - версия MInstAll
{winver} - версия Windows
• Добавлены подсказки для сложных параметров в окне редактирования.
Версия: 1.0.1.35
• Добавлено окно с описанием, открывается при клике средней кнопкой мыши по приложению, а также при двойном клике в режиме "Инсталлятора".
• Добавлено сохранение состояния "На весь экран" для окна выбора иконки из dll-файла.
Версия: 1.0.1.34
• Добавлена функция создания ярлыков в меню "Пуск" для всех портативных приложений (для использования на WinPE).
Версия: 1.0.1.33
• В контекстное меню для полей "Название программы" и "Версия" в окне редактирования, по левому клику (по стрелке), добавлены пункты "Копировать" в буфер обмена и "Вставить" из буфера обмена. При нажатии "Вставить" значение будет заменено на данные из буфера.
• В контекстное меню главного окна, добавлен пункт "Заменить", который заменяет текущее приложение на то, что было предварительно скопировано во внутренний буфер. Для тех случаев, когда одно и то же приложение есть в нескольких профилях, и при обновлении приложения, можно скопировать все параметры во внутренний буфер и заменить это приложение в другом профиле.
Версия: 1.0.1.32
• Исправлен экспорт списка приложений в буфер обмена.
Версия: 1.0.1.31
• Исправлена потеря атрибута "выбран по умолчанию" при сортировки приложений.
• Добавлено автопереключение в режим редактирования при нажатии Ctrl+C.
Версия: 1.0.1.30
• Добавлены подгруппы.
Версия: 1.0.1.29
• Исправлена сортировка иконок загружаемых из dll-файла.
Версия: 1.0.1.28
• Удалена иконка с кнопки "Отменить", так как она слишком привлекает внимание, а так же ассоциируется с "Ошибкой".
Версия: 1.0.1.27
• Добавлена функция для проверки наличия установленного .NET Framework, для включения проверки, в поле GUID нужно указать специальный код:
NF3.5SP1 - для проверки наличия Microsoft .NET Framework 3.5 SP1
NF4.5C - для проверки наличия Microsoft .NET Framework 4.5 Client
NF4.5F - для проверки наличия Microsoft .NET Framework 4.5 Full
Версия: 1.0.1.26
• Добавлена возможность кастомизации под конкретную компанию, изменение логотипа, надписи в заголовке окна и т.п. (на платной основе).
Версия: 1.0.1.25
• Исправлены некоторые ошибки, возникающие на дисках с аппаратной защитой от записи, остается не исправленной ошибка при загрузки ассоциированной иконки, это ошибка в штатной функции компилятора, поэтому исправление пока не представляется возможным. Для избавления от окна с ошибкой, укажите свою иконку для приложения, при загрузке которого возникает ошибка в режиме "Чтения" на дисках с аппаратной защитой от записи. Что бы избавится от окна с ошибкой при закрытии приложения, добавьте атрибут "Только для чтения" для файла minst.ini перед включением аппаратной защиты.
Версия: 1.0.1.24
• Исправлен механизм плавного изменения размера для области описания.
Версия: 1.0.1.23
• Добавлен режим ReadOnly, в файле конфигурации minst.ini укажите параметр ReadOnly=1, в этом режиме:
Не загружаются иконки.
Не проверяется правильность путей (эта функция реализована совместно с функцией загрузки иконок).
Профили загружаются быстрее.
Текущие настройки не сохраняются.
Иконки все равно отображаются (т.к. в последних версиях было добавлено кеширование иконок).
Версия: 1.0.1.21
• Исправлен выход без сохранения после запуска портативного приложения, возникающий если включена опция закрытия оболочки после запуска портативного приложения.
Версия: 1.0.1.20
• Изменена иконка для приложений не совместимых с текущей ОС, на менее раздражающую. Изменен цвет текста на серый для таких приложений.
• Добавлена опция для закрытия оболочки после запуска портативного приложения. Включить/Выключить можно в контекстном меню.
Версия: 1.0.1.19
• Исправлено отображение текущего состояния в поле описания, во время установки, для приложений с включенной опцией копирования во временную папку.
Версия: 1.0.1.18
• Оптимизирован способ загрузки профилей, добавлен временный кэш иконок. После появления списка приложений, иконки отображаются из временного кэша, после полной загрузки профиля (после проверки правильности путей) иконки загружаются из файла приложения (или из файла иконки). Изменения будут заметны после пересохранения профилей.
• Исправлена ошибка приводящая к зависанию приложения, если за один сеанс (до перезапуска оболочки) было загружено более 3500 приложений. Другими словами, если вы за сеанс открывали более 17 раз профиль в котором 200 приложений.
• Добавлен диалог выбора иконок из библиотеки (dll-файла), автоматически появляется при выборе *.dll в качестве иконки. Добавлена библиотека iconapp.dll с иконками наиболее распространенных приложений.
• Добавлена возможность отключения редиректа на 64-битной ОС для исполняемых *.cmd и *.bat файлов. Для отключения редиректа, нужно указать ключ /x64 этот ключ обрабатывает сама оболочка MInstAll, он не передается в целевое приложение, на 32-битной ОС этот ключ не учитывается.
Версия: 1.0.1.15
• В контекстное меню "Файл" добавлена функция "Сохранить как".
• Добавлена функция для перезагрузки в процессе установки приложений с последующим продолжением установки. Если приложение требует перезагрузки, которую нельзя избежать или отложить, для него нужно включить опцию "Перезагрузить ОС" в параметрах приложения.
• Задействован ProgressBar при загрузки и сохранении профиля.
Версия: 1.0.1.14
• Восстановлена работа всплывающего сообщения при попытке снять выбор с приложения, если его требует другое приложение. Данная функция была отключена при переходе на мультистатусное состояние пунктов (CheckBox True, CheckBox False, RadioButton True, RadioButton False, Portable True) из-за необходимости доработки данной функции под мультистатусный режим.
• Добавлено всплывающее сообщение при попытке выбрать приложение не совместимое с текущей версией Windows. Сообщение всплывает только в режиме "Установки".
• Добавлено всплывающее сообщение при попытке выбрать уже установленное приложение. Сообщение всплывает только в режиме "Установки".
Версия: 1.0.1.13
• Исправлена ложная индикация ошибки, при запуске портативного приложения без ключей.
• Исправлено появление записи в поле "Включать установку" от предшествующего редактируемого приложения при добавлении нового приложения.
Версия: 1.0.1.12
• В контекстное меню добавлен пункт переключения режимов.
• В справочник ключей добавлена кнопка для запуска skf.exe, кнопка отображается если рядом с MInst.exe лежит skf.exe.
skf.exe это Silent key finder - утилита для идентификации инсталлятора с целью определения ключей для "тихой" установки.
Версия: 1.0.1.11
• Добавлена задержка (1 секунда) после инсталляции приложения перед проверкой по GUID. Задержка выполняется, только если включена функция проверки (то есть указан GUID).
• Исправлена функция проверки наличия установленных приложений через реестр. Неверные данные были после деинсталляции некоторых приложений, т.к. штатный деинсталлятор удалял не все параметры из реестра.
Версия: 1.0.1.10
• Добавлена локализация новых пунктов интерфейса.
Версия: 1.0.1.9
• В настройки добавил три варианта режима при запуске оболочки:
"Запускать в режиме инсталлятора"
"Запускать в режиме редактора"
"Запускать в последнем режиме"
Версия: 1.0.1.8
• Добавлен второй GUID, можно указывать два GUID разделив их знаком ";" (Больше двух GUID указывать нельзя).
Версия: 1.0.1.7
• Добавлено, при запуске с сетевых дисков, кэширование исполняемого файла (MInst.exe) в Swap.
• Добавлена функция копирования всех файлов (из папки с приложением, вместе с подпапками) во временную папку перед установкой. Данную опцию нужно включать если дистрибутив лежит на сетевом диске, при этом дистрибутивы надо сортировать по папкам, что бы не копировать лишние файлы.
• Добавлено, при наведении указателя мыши на приложение не совместимое с текущей ОС, в поле описания отображается предупреждение красным цветом.
• Изменено, описание для приложений будет отображаться красным цветом, если последний символ в описании знак восклицания.
• Другие мелкие исправления и улучшения.
Версия: 1.0.1.1
• Исправлена отзывчивость приложения в первые секунды после применения изменений параметров приложения. Баг появился после внедрения специальной иконки для групп взаимо-исключаемых приложений.
Версия: 1.0.1.0
• Добавлено запоминание для групп параметра "свернута/развернута".
Версия: 1.0.0.99
• Исправлена функция группового выбора, баг появился после внедрения специальной иконки для групп взаимо-исключаемых приложений.
Версия: 1.0.0.98
• Добавлено, для взаимоисключающих приложений вместо CheckBox теперь RadioButton.
• Добавлена проверка совместимости с текущей ОС на основании заданных параметров для приложения. Несовместимые с текущей системой приложения помечаются специальной иконкой.
• Изменено, количество выбранных/всего в названиях групп по умолчанию отключено, включить можно отдельно для конкретного профиля в настройках профиля.
Версия: 1.0.0.93
• Исправление, при сохранении "профиля по умолчанию" отключалась функция "добавление перетаскиванием", баг появился в версии 1.0.0.88.
Версия: 1.0.0.92
• Различные мелкие исправления и улучшения.
• Изменено, функция "Выбрать все" пропускает уже установленные приложения и приложения из группы взаимно исключаемых.
При загрузке профиля, галочки для уже установленных приложений не ставятся. Перед сохранением профиля, нужно восстановить состояние галочек нажатием кнопки "По умолчанию".
• Добавлена возможность добавлять ссылки для переходов между профилями, вместо приложения нужно указать путь к ini-файлу профиля. Если название приложения указать "..", то при двойном клике вместо контекстного меню будет переход (в обычном профиле в режиме "Установки", например для быстрого возврата в главное меню).
Версия: 1.0.0.88
• Добавлено сохранение текущих настроек сразу после сохранения профиля по умолчанию (исправляет не подхват настроек при запуске второй копии MInst.exe).
• Добавлен ключ MInst.exe /Minimized запуск в свернутом состоянии.
• Добавлен ключ MInst.exe /lock для блокировки режима редактора.
• Добавлен ProgressBar на кнопке в панели задач для Win 8.1.
• Добавлен индикатор процесса выполнения на кнопке в панели задач для Win XP (только в свернутом состоянии, вместо названия отображение % выполнения).
Версия: 1.0.0.85
• Изменено, новые профили создаются в папке с профилями.
• Добавлено, расположение папки с профилями можно изменить, параметр ProfilesDir в файле настроек.
• Сохранение "прилипшего" к краю экрана состояния.
• Другие мелкие улучшения
Версия: 1.0.0.80
• Добавлена проверка наличия уже установленных приложений
• Добавлена проверка результата установки приложения
Версия: 1.0.0.78
• Добавлена поддержка файла локализации minst.lng
• Добавлена поддержка сохранения профилей в Unicode
Версия: 1.0.0.76
• Исправлено ложное срабатывание помощника по совместимости программ
• Исправлено не сохранение профиля в режиме "Установка"
• Другие мелкие исправления и улучшения
Версия: 1.0.0.72
• Исправлено, если нет ни одного профиля, при запуске программа создает новый профиль, но при этом не работала (до перезапуска) функция добавления перетаскиванием из проводника.
• Исправлено смещение окна на 3-5 пикселей выше экрана при прилипании к краям экрана на Windows 8.1.
Версия: 1.0.0.71
• Исправлено искажение ассоциированных иконок.
• Исправлено срабатывание двойного клика при двойном клике по названию группы, теперь группы можно сворачивать/разворачивать двойным кликом по названию.
• Добавлена функция прилипания к краям экрана, вкл/выкл можно в контекстном меню. Удобно использовать при добавлении приложений перетаскиванием из проводника (файлового менеджера).
Версия: 1.0.0.70
• Добавлена поддержка иконок из *.dll
Версия: 1.0.0.69
• Добавлена поддержка reg-файлов, информация будет импортироваться в реестр без подтверждения.
На 64-битной ОС информация по умолчанию добавляется в ветку Wow6432Node, но можно импортировать в основную ветку, для этого надо указать ключ "/x64", этот ключ не влияет на работу команды в 32-битной ОС.
Версия: 1.0.0.68
• Исправлена реакция CheckBox на быстрое включение/выключение галочки.
Версия: 1.0.0.67
• Добавлено предупреждение при попытке снять выбор с приложения, если его требует другое приложение.
• Добавлена возможность изменять размер области описания.
Версия: 1.0.0.64
• Мелкие исправления.
Версия: 1.0.0.62
• Добавлено, добавление приложений перетаскиванием.
• Добавлено воспроизведения звука при завершении.
Версия: 1.0.0.61
• Исправлена функция добавления файла из корня диска, которая приводила к появлению двойного слеша, который при определенных условиях мог приводить к зависанию приложения.
Версия: 1.0.0.60
• Изменен принцип работы с профилями.
Имена ini-файлов профилей можно переименовывать как угодно, хранить их можно в подкаталоге Profiles,
исключение файл minst.ini, он должен быть рядом с MInst.exe т.к. он одновременно и файл настроек.
Версия: 1.0.0.58
• Исправление, при операциях с группами (переименование, создание новой и так далее) слетал размер колонки версии, который был изменен вручную в ini-фйле.
• Добавлено открытие файлов любого формата через ассоциированное приложение.
• Добавлена поддержка переменных в активных ссылках в поле "Описание".
Версия: 1.0.0.57
• Увеличена скорость загрузки иконок.
Версия: 1.0.0.56
• Добавлено Вкл/Выкл авторазмера окна по высоте (в контекстном меню).
• Добавлено сохранение ширины колонки для версии (в ini-профиле параметр VerWidth=80 ).
• Добавлен пункт в контекстное меню "Открыть профиль в текстовом редакторе".
• Изменен способ чтения свойств exe-файлов для автозаполнения названия и версии.
Версия: 1.0.0.55
• Исправление, при изменении пути к *.msi пакету, ключи для "тихой" установки автоматически добавлялись старым способом.
• Добавлена проверка заполнения полей обязательных параметров перед применением.
Версия: 1.0.0.54
• Доработан механизм установки пакетов *.msi и *.msu теперь в поле "Путь к приложению" нужно указывать путь к пакету а не к установщику.
Соответственно теперь будут работать функции: автопроверка наличия файла, открыть папку, удалить файл с диска, копировать во временную папку для пакетов msi и msu.
• Добавлен новый параметр "Статус программы".
• Другие мелкие улучшения.
Версия: 1.0.0.50
• Добавлено контекстное меню для поля описания приложения, с функциями Вырезать/Копировать/Вставить.
• Добавлена функция запуска оболочки с конкретным профилем, пример: MInst.exe {Patch}\myprofile.ini
• Добавлена не стандартная переменная {P}, которая принимает значения x86 или x64 в зависимости от разрядности текущей ОС.
Версия: 1.0.0.49
• Новый диалог удаления
• Добавлена ссылка на панель управления "Программы и компоненты" в контекстное меню
• Добавлено отдельное поле для URL
• Добавлены активные ссылки в поле "Описание"
• Добавлено отдельное поле для версии
• Теперь всегда отображается количество выбранных приложений в нижнем левом углу
• Добавлена функция "Выбор по умолчанию"
Версия: 1.0.0.45
• Добавлен ProgressBar.
• Добавлена кнопка "Справка", пока справки нет автоматическая переадресация на форум.
• Добавлен профиль "Панель управления (Win7/8)" для демонстрации возможностей профиля с атрибутом "Для запуска портативного софта".
• Добавлена переменная {Root} = на папку выше переменной {Patch}.
Версия: 1.0.0.44
• Добавлен тип профилей, для запуска портативных приложений.
Что бы сделать специальный профиль для запуска портативных приложений, нужно поставить галочку в окне свойств профиля (окно описания профиля).
В режиме "Установка" портативные программы можно запускать по двойному клику,
в режиме "Редактирование" будет открываться окно редактора.
Режим "Установка" это когда скрыта боковая панель, а в контекстном меню нет пунктов по редактированию.
Режимы переключаются кнопкой в верхнем правом углу.
Версия: 1.0.0.43
• Изменено, цвета визуальных элементов, берутся из цветовой схемы темы оформления Windows.
Версия: 1.0.0.42
• Увеличена скорость загрузки профиля.
Версия: 1.0.0.41
• Добавлен поиск приложений входящих в группы взаимо-исключаемых.
Версия: 1.0.0.41
• Исправлена функция поиска приложений входящих в группы взаимо-исключаемых (отключен поиск по маске).
Версия: 1.0.0.40
• Добавлен поиск приложений входящих в группы взаимо-исключаемых.
Версия: 1.0.0.39
• Добавлено закрытие всех окон приложения (кроме главвного) по "Esc".
• Отсортирован порядок визуальных элементов для правильной табуляции при нажатии на "Tab".
• Добавлены "горячие" клавиши для кнопок "Добавить" и "Применить", буквы подчеркиваются при нажатии на "Alt".
Версия: 1.0.0.38
• Исправлена ошибка с названиями групп при создании нового профиля (ошибка появилась в версии 1.0.0.37).
• Добавлено предупреждение перед запуском установки выбранных приложений, если были изменения.
Версия: 1.0.0.37
• Добавлено в название групп количество приложений выбранных/всего.
• Новые иконки на кнопках.
• Изменено название программы на "MInstAll".
Версия: 1.0.0.36
• Добавлено управление с клавиатуры:
Клавиша = Функция
Стрелка влево = свернуть текущую группу
Стрелка вправо = развернуть текущую группу
Insert = Выбрать/Снять выбор со всей группы
Пробел = Выбрать/Снять выбор с текущего приложения
F12 = Запустить установку выбранных приложений
Версия: 1.0.0.34
• Добавлена возможность сворачивать группы.
• В контекстное меню добавлены пункты: "Свернуть все группы" и "Развернуть все группы".
Версия: 1.0.0.33
• Исправлена авто подставка переменной {Disk}
Если запускать Minst.exe с системного диска, то вместо переменной {Disk} добавлялась переменная %SystemDrive%.
Версия: 1.0.0.32
• Изменено, переменная {SoftPatch} и каталог с софтом по умолчанию теперь одно и тоже.
Каталог с софтом по умолчанию задается для каждого профиля, если не задавать, то он равен переменной {Patch}.
Версия: 1.0.0.31
• Отключена зависимость регистра для групп несовместимости и зависимых приложений
• Добавлен ключ "/edit"
Режим редактора можно блокировать, прописав в файле minst.ini параметр Lock=1, значение 0 - включает режим редактора.
При запуске с ключем MInst.exe /edit режим редактора будет включен не зависимо от значения Lock в файле конфигурации.
Версия: 1.0.0.30
• Добавлены функции Exclude и Include (группа взаимо-исключаемых и квлючение выбора другого приложения).
• Исправлена недоработка предшествующей версии.
• Добавлена возможность изменять данные в справочнике ключей.
Версия: 1.0.0.27
• Исправлена функция проверки правильности путей, ошибка появилась после добавления функции кеширования иконок.
• Добавил отображение прогресса установки на кнопке в панели задач.
• Исправления различных ошибок возникающих при неправильном/нелогичном поведении пользователя.
Версия: 1.0.0.26
• Добавлена специальная иконка для приложений, которые были установлены.
• Добавлена цветовая подсветка пунктов с неправильными путями.
Версия 1.0.0.25
• Добавлена возможность задавать каталог с софтом по умолчанию
• Добавлена возможность создавать новые профили
• Добавлено удаление всех выбранных приложений
• Добавлена сортировка программ кнопками вверх/вниз
Версия: 1.0.0.24
• Исправлена ошибка приводящая к неактивному состоянию кнопки "Применить" при изменении пути к приложению.
Версия: 1.0.0.23
• Увеличена скорость загрузки профиля при работающем антивирусе (нужно пересохранить профили).
• Добавлен запуск установки текущего приложения без ключей (в контекстном меню).
Версия: 1.0.0.21
• Исправлена очень медленная загрузка профиля (может показаться, что программа зависла) при работающем антивирусе Microsoft Security Essentials.
Версия: 1.0.0.20
• Уменьшена нагрузка на процессор
• Уменьшено потребление оперативной памяти
• Увеличена скорость загрузки
• Другие мелкие улучшения в интерфейсе
• Добавлена новая переменная {Disk} - буква диска с которого запущен MInst.exe
• Добавлен поиск
Версия: 1.0.0.19
• Добавлена автопрокрутка списка при инсталляции программ.
• Добавлен подсчет общего количества программ в списке.
Версия: 1.0.0.17
• Исправлены ошибки в функциях, добавленных в предшествующей версии.
Версия: 1.0.0.16
• Добавлено визуальное информирование о процессе сохранения профиля.
Версия: 1.0.0.15
• Добавлено выделение установщика при открытии папки размещения установщика программы.
Версия: 1.0.0.14
• Добавлена функция открытия папки размещения установщика программы.
Версия: 1.0.0.13
• Увеличена скорость загрузки иконок приложений.
Версия: 1.0.0.12
• Добавлена возможность менять иконки на свои.
• Добавлена функция скрытого запуска.
Можно указывать свои иконки для приложений, в отличие от GPInst, здесь комбинированный способ, одновременно можно использовать как иконку из приложения так и свою. Иконки в формате *.ico ни каких заморочек с редактированием ресурсов.
Функция скрытого запуска позволяет скрывать окно запущенного приложения, актуально для запуска bat-ников.
Добавлены пункты "Перезагрузка" и "Выключение", эти пункты добавлены как приложения, их можно удалить.
Версия: 1.0.0.11
• Добавлена сортировка перетаскиванием в справочнике ключей.
• Добавлено описание для профиля.
• Добавлено редактирование имени и описания для профилей через программу.
• Другие мелкие исправления и улучшения, оптимизация кода.
Версия: 1.0.0.10
• Изменен способ вывода описания программ.
• Изменен дизайн главного окна.
Версия: 1.0.0.9
• Доработан справочник ключей:
Добавление, удаление, сортировка ключей через программу.
Двойной клик по ключу - добавление ключа и закрытие справочника
Кнопка "Добавить ключ" - добавляет ключ без закрытия справочника, что бы можно было добавить еще ключ.
Версия: 1.0.0.8
• Добавлен список ключей для инсталяторов (файл MInst.Key).
Версия: 1.0.0.7
• Выпущена первая публичная версия, с целью быстро выявить все ошибки и недостатки, т.к. если тестировать буду только я, то некоторые ошибки я не встречу очень долго или вообще не встречу, т.к. интуитивно использую программу так, как предусмотрено логикой программного кода. Нелогичное поведение пользователя, может вызывать внутренние ошибки в логике, именно их я планирую выявить и исправить.
Версия: 1.0.0.0
01.08.2013 Вдохновленный идеей GPInst и разочарованный стабильностью ее работы, я решил написать ее клон под названием MInst лишенный всех ее недостатков.


Ключи инсталляторов

Для вывода справки выберите инсталлятор.
Утилита Silent key finder поможет идентифицировать инсталлятор.
Полезные ссылки:
Ключи командной строки для модифицированных 7z SFX модулей от Олега Щербакова
Ключи командной строки для: Tarma InstallMate, Tarma Installer, Tarma QuickInstall.

Содержание Ключи инсталляторов

Inno Setup
NSIS
Windows MSI
InstallShield
Smart Install Maker
WISE Installer


Inno Setup

Бесплатный инсталлятор для программ Windows.
Официальный сайт:
http://www.jrsoftware.org/
Справка:
http://www.jrsoftware.org/ishelp/
/HELP, /?
Вызов справки. Игнорируется, если параметр UseSetupLdr в разделе [Setup] установлен "no".
/SP-
Отключает страницу "Эта программа установит... Вы хотите продолжить?" инсталятора.
Выполнится только если DisableStartupPrompt секции [Setup] равна yes.
/SILENT, /VERYSILENT
Установка в ускоренном или очень ускоренном режиме. При установке в ускоренном режиме
окно мастера и фоновое окно мастера не отображаются, отображается только окно прогресса.
При очень ускоренной установке окно прогресса тоже не отображается. Остальная установка
проходит как обычно - отображаются сообщения об ошибках в ходе установки, страница
приветствия (если ее отображение не отменено директивой DisableStartupPrompt или
параметром '/SP-' командной строки).
Если после установки необходима перезагрузка, команды '/NORESTART' не дано и установка
проходит в ускоренном режиме, появится сообщение "Перезагрузить компьютер?". Если режим
установки очень ускоренный, система перезагрузится не спрашивая.
/SUPPRESSMSGBOXES
Заставляет программу установки подавлять сообщения.
Имеет эффект только в сочетании с '/SILENT' и '/VERYSILENT'.
/LOG
Указывает инсталятору создать log-файл в папке TEMP для подробного отчета о действиях
и событиях в секции [Run], предпринятых в ходе установки. Применяется при отслеживании
ошибок. Например, если вы подозреваете, что файл не был удален, хотя должен был,
log-файл сообщит, что файл былдействительно пропущен и почему.
log-файлу присваивается уникальное имя на базе текущей даты. (Существующие файлы не
перезаписываются и не дополняются).
Информация, содержащаяся в log-файле, техническая и поэтому не может быть понята
пользователем.
/LOG="filename"
Параметр похож на /LOG, но в отличие от него позволяет указать фиксированный
путь/имя файла для log-файла. Если файл с указанным именем уже существует, он будет
заменен. Если файл не может быть создан, установка прервется и выдаст сообщение
об ошибке.
/NOCANCEL
Не дает пользователю прервать установку, отключая кнопку Отменить и игнорируя клики на
кнопке Закрыть. Используется в комбинации с '/SILENT' или '/VERYSILENT'.
/NORESTART
Указывает инсталятору не перезагружать компьютер даже если это необходимо.
/RESTARTEXITCODE=exit code
Задает инсталятору код, который он должен возвратить, если необходима перезагрузка.
Используется с '/NORESTART'.
См. также Коды выхода инсталятора. (кому интерестно, могу выложить или же доступно в хелпе)
/CLOSEAPPLICATIONS
Заставляет программу установки закрывать приложения, использующие файлы, которые должны быть обновлены путем установки, если это возможно.
/NOCLOSEAPPLICATIONS
Запрещает программе установки закрывать приложения, использующие файлы, которые должны быть обновлены путем установки. Если /CLOSEAPPLICATIONS был использован, то этот параметр игнорируется.
/RESTARTAPPLICATIONS
Заставляет программу установки перезапускать приложения, если это возможно. Если /CLOSEAPPLICATIONS был использован, то этот параметр игнорируется.
/NORESTARTAPPLICATIONS
Запрещает программе установки перезапускать приложения. Если /RESTARTAPPLICATIONS был использован, то этот параметр игнорируется.
/LOADINF="filename"
Указывает инсталятору загрузить параметры установки из указанного файла после проверки
командной строки. Этот файл может быть подготовлен с помощью '/SAVEINF="filename"'.
Не забудьте ставить кавычки при использовании имен, содержащих пробелы.
/SAVEINF="filename"
Указывает инсталятору сохранять параметры установки в указанный файл.
Не забудьте ставить кавычки при использовании имен, содержащих пробелы.
/LANG=language
Задает используемый язык. language задает имя языка, заданного в параметре секции
[Languages]. При использовании параметра /LANG появляется диалог Выбор языка установки.
/DIR="x:\dirname"
Меняет имя папки, заданное по умолчанию, на странице Выбор папки назначения.
Должен быть задан полный путь.
/GROUP="folder name"
Меняет имя папки на странице Выбор папки меню Пуск. Если директива
DisableProgramGroupPage секции [Setup] равна yes, этот параметр командной строки
игнорируется.
/NOICONS
Указывает инсталятору проверять, выбрана ли команда Не создавать значков на странице
Выбор папки меню Пуск.
/COMPONENTS="comma separated list of component names"
Меняет выбраные по умолчанию компоненты. В этом случае параметр командной строки
указывает инсталятору менять тип установки на Выборочный.
/PASSWORD=password
Задает пароль. Если не указана директива Password секции [Setup],
этот параметр игнорируется. Если введен неправильный пароль, параметр
также игнорируется.


NSIS

Бесплатный инсталлятор для программ Windows.
Официальный сайт:
http://nsis.sourceforge.net/
Справка:
http://nsis.sourceforge.net/Docs/
/S
Указывает на "тихую" установку.
/DIR="x:\dirname"
Задает директорию установки.


Windows MSI

Инсталлятор для программ Windows.
</package | /i> <Product.msi>
Установка или настройка продукта
/a <Product.msi>
Административная установка - установка продукта в сеть
/j<u|m> <Product.msi> [/t <список преобразований>] [/g <код языка>]
Объявление о продукте: "m" - всем пользователям; "u" - текущему пользователю
</uninstall | /x> <Product.msi | Код_продукта>
Удаление продукта
/quiet
Тихий режим, без взаимодействия с пользователем
/passive
Автоматический режим - только указатель хода выполнения
/q[n|b|r|f]
Выбор уровня интерфейса пользователя
n - Без интерфейса
b - Основной интерфейс
r - Сокращенный интерфейс
f - Полный интерфейс (по умолчанию)
/help
Вывод справки по использованию
/norestart
Не перезапускать после завершения установки
/promptrestart
Запрашивать перезапуск при необходимости
/forcerestart
Всегда перезапускать компьютер после завершения установки
/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <файл_журнала>
Параметры ведения журнала
i - сообщения о состоянии
w - сообщения об устранимых ошибках
e - все сообщения об ошибках
a - запуски действий
r - записи, специфические для действий
u - запросы пользователя
c - начальные параметры интерфейса пользователя
m - сведения о выходе из-за недостатка памяти или неустранимой ошибки
o - сообщения о недостатке места на диске
p - свойства терминала
v - подробный вывод
x - дополнительные отладочные сведения
+ - добавление в существующий файл журнала
! - сбрасывание каждой строки в журнал
* - заносить в журнал все сведения, кроме параметров "v" и "x"
/log <файл_журнала>
Равнозначен /l* <файл_журнала>
/update <Update1.msp>[;Update2.msp]
Применение обновлений
/uninstall <Код_Guid_обновления>[;Update2.msp] /package <Product.msi | код_продукта>
Удаление обновлений продукта
/f[p|e|c|m|s|o|d|a|u|v] <Product.msi | код_продукта>
Параметры восстановления
p - только при отсутствии файла
o - если файл отсутствует или установлена старая версия (по умолчанию)
e - если файл отсутствует или установлена такая же либо старая версия
d - если файл отсутствует или установлена другая версия
c - если файл отсутствует или контрольная сумма не совпадает с подсчитанным значением
a - принудительная переустановка всех файлов
u - все необходимые элементы реестра, специфические для пользователя (по умолчанию)
m - все необходимые элементы реестра, специфические для компьютера (по умолчанию)
s - все существующие ярлыки (по умолчанию)
v - запуск из источника с повторным кэшированием локальных пакетов
[PROPERTY=PropertyValue]
Настройка общих свойств, подробнее здесь.


InstallShield

Инсталлятор для программ Windows.
Официальный сайт:
http://www.installshield.com/
/s
Автоматическая установка.
/sms
Заставит инсталлятор дождаться окончания установки.
/r
Создание файла ответов:
1. Запустите приложение из командной строки, используя ключ /r (например, Setup.exe /r)
2. Пойдет процесс установки, вы будете отвечать на вопросы - все как обычно. Главное, не выбирайте опцию перезагрузки компьютера сразу после установки ("Restart the computer now")
3. После окончания установки зайдите в вашу системную директорию (C:\Windows) и извлеките оттуда файл setup.iss. Перед автоматической установкой положите файл в директорию, где лежит ваша программа.
/v"/qn REBOOT=ReallySuppress"
Чтобы автоматически установить приложение, использующее Basic MSI,
вам нужно указать ключи /s /v"...".
Многоточие нужно заменить на ключи, которые вы хотите передать непосредственно Windows Installer (msiexec).


Smart Install Maker

Инсталлятор для программ Windows.
Официальный сайт:
http://ru.sminstall.com
/s
Скрытая установка с данными установленными по умолчанию.
/nc
Полный запрет пользователю отменить запущенную установку (блокировка кнопок «отмена» и «закрытие окна»).
/nr
Не выводить сообщение о требуемой перезагрузки компьютера по окончании процесса установки.
/l=language
Выбор языка для установки приложения. language — это название, которое следует заменить на любой доступный пакет, к примеру, «English» или «Russian». В случае, если параметр /l используется, то диалог выбора языка не отобразится.
/p=path
Изменение директории для установки приложения.
/g=name
Изменение программной группы.
/pw=password
Установка пароля для установки приложения. В случае, если используется параметр /pw=, то диалог ввода пароля не отобразится.


  • MInstAll
  • Ключи инсталляторов
  • WISE Installer
MInstAll © 2015 Дмитрий Малгин

WISE Installer

Инсталлятор для программ Windows.
/s
"тихая" установка.


Описание функций

  • MInstAll
  • Описание функций
MInstAll © 2015 Дмитрий Малгин

Содержание Описание функций

Установка иконок из exe-шника инсталлятора, из ico-файлов, из dll
Блокировка режима редактора
Авто запуск установки для профиля по умолчанию
Функции Exclude и Include
Спец. профиль для запуска портативных приложений
Импорт reg-файлов
Поддержка Unicode
Перевод на другие языки
Проверка наличия уже установленных приложений
Отключение редиректа на 64-битной ОС для *.cmd и *.bat файлов
Идентификация инсталлятора с целью определения ключей для "тихой" установки
Описание программы в отдельном окне
Дополнительная информация в заголовке главного окна
Открытие каталога с дистрибутивом через файловый менеджер


Установка иконок из exe-шника инсталлятора, из ico-файлов, из dll

Путь к иконке:
%WinDir%\system32\shell32.dll,21
где 21 - номер иконки


Блокировка режима редактора

Все настройки хранятся в файле minst.ini, это профиль по умолчанию.
Для блокировки режима редактора, нужно установить значение параметра Lock=1
[MInst]
...
Lock=1
...
Можно всегда запускать программу в режиме редактора, не зависимо от значения Lock, с ключем /edit
MInst.exe /edit


  • MInstAll
  • Описание функций
  • Авто запуск установки для профиля по умолчанию
MInstAll © 2015 Дмитрий Малгин

Авто запуск установки для профиля по умолчанию

Запускать с ключем /t
MInst.exe /t 20
запуск установки через 20 сек.


Функции Exclude и Include

Exclude:
Для нескольких приложений, взаимно несовместимых, указываем одну и ту же группу несовместимости, в редакторе она называется "Группа взаимно исключаемых".
Название группы любое, но соответственно одно и то же для несовместимых приложений. Пункт "Выйти из программы установки" в группе взаимно исключаемых "End".
Include:
При выборе приложения, оно может автоматически выбирать для установки другое приложение, в поле "Включать установку" указываем название приложения которое включится автоматически.


Спец. профиль для запуска портативных приложений

Что бы сделать специальный профиль для запуска портативного софта, нужно поставить галочку в этом окне:
В режиме "Установка" портативные программы можно запускать по двойному клику,
в режиме "Редактирование" будет открываться окно редактора.
Режим "Установка" это когда скрыта боковая панель, а в контекстном меню нет пунктов по редактированию.
Режимы переключаются кнопкой в верхнем правом углу.


Импорт reg-файлов

На 64-битной ОС информация по умолчанию добавляется в ветку Wow6432Node, но можно импортировать в основную ветку, для этого надо указать ключ "/x64", этот ключ не влияет на работу команды в 32-битной ОС.


Поддержка Unicode

Профиль будет сохранятся в Unicode если установить параметр Unicode=1
[MInst]
...
Unicode=1
...


Перевод на другие языки

English (Google translate)
http://checkdevice.narod.ru/language/english/minst.lng


Проверка наличия уже установленных приложений

Проверка наличия установленных приложений делается для предотвращения повторной установки, для экономии времени, а так же для контроля за результатом инсталляции приложения.
Проверка через реестр с помощью GUID:
Для включения проверки, нужно указать правильные GUID и версию, в таком виде, в котором она прописывается в реестре, а не так, как автоматом определилась при добавлении приложения.
Определить без ошибочно можно с помощью Check Device
Можно указывать два GUID разделив их знаком ";" (Больше двух GUID указывать нельзя)
Например когда приложение двух разрядное, и у каждой разрядности свой GUID.
Версию можно сократить, отбрасывая цифры после точки. Например если в реестре версия 3.4.0.30460 в MInstAll можно указать 3.4.0 или 3.4 или даже 3.
Если установлена такая же или более новая версия, приложение помечается зеленой галочкой.
Если установлена более старая версия, приложение помечается желтым восклицательным знаком.
Если в реестре нестандартная версия с буквами, словами и другой ерундой, в MInstAll указываем точно так же (без сокращений).
В операционных системах, где .NET Framework является частью системы его нет в списке установленных программ, поэтому в программе есть встроенный механизм проверки.
Для проверки .NET Framework указываем в поле GUID спец. код:
NF3.5SP1 - для проверки наличия Microsoft .NET Framework 3.5 SP1
NF4.5C - для проверки наличия Microsoft .NET Framework 4.5 Client
NF4.5F - для проверки наличия Microsoft .NET Framework 4.5 Full
Проверка по наличию файла:
Если по GUID проверять не представляется возможным, можно проверять по наличию файла, при этом версия не учитывается.
Для включения проверки, в поле GUID указываем путь к файлу, для универсальности используем переменные, например:
если приложение 32-битное:
%ProgramFiles%\Microsoft Office\Office14\WINWORD.EXE
если приложение 64-битное:
%SystemDrive%\Program Files\Microsoft Office\Office14\WINWORD.EXE
Второй вариант, для тех случаев, когда приложение ставится в зависимости от разрядности ОС, на x64 ставится 64-битная версия, а на x86 ставится 32-битная версия.


Отключение редиректа на 64-битной ОС для *.cmd и *.bat файлов

При необходимости, можно отключить редирект, указав ключ /x64 этот ключ обрабатывает сама оболочка MInstAll, он не передается в исполняемый файл.


Идентификация инсталлятора с целью определения ключей для "тихой" установки

В комплекте идет утилита skf.exe, если она не определила инсталлятор, то можно попытаться запустить установщик с ключами "/?" и "/Help", для этого есть специальные кнопки.


Описание программы в отдельном окне

Для открытия описания в отдельном окне, щелкните средней кнопкой мыши по интересующему приложению.
Из режима "Установки" данное окно будет открываться по двойному клику.


Дополнительная информация в заголовке главного окна

Можно выводить свою информацию в заголовке окна, за нее отвечает параметр Caption в файле minst.ini, в заголовке можно использовать переменные: {mver}, {winver}, {winbuild}, {winname}, {p}.
{mver} - Версия MInstAll
{winver} - Версия ОС в привычном представлении
{winbuild} - Номер сборки Windows
{winname} - Название операционной системы
Так же эти переменные можно использовать в описании профиля.


Открытие каталога с дистрибутивом через файловый менеджер

Путь к файловому менеджеру и ключи запуска задаются в файле minst.ini параметры FMPath и FMKey. Для параметра FMKey доступны две дополнительные переменные {OpenPathFile} = путь к файлу или {OpenPathDir} = путь к каталогу.
Пример для JustManager:
FMPath={Patch}\Portable\JustManager\JustManager.exe
FMKey={OpenPathDir}
Пример для Total Commander:
FMPath={Patch}\Portable\totalcmd\TOTALCMD.EXE
FMKey={OpenPathFile} r="%UserProfile%\Downloads" /i="{Patch}\Portable\totalcmd\wincmd.ini" /f="{Patch}\Portable\totalcmd\wcx_ftp.ini"


FAQ

  • MInstAll
  • FAQ
MInstAll © 2015 Дмитрий Малгин

Содержание FAQ

Выбор приложений по умолчанию
Дополнительные функции в контекстном меню
Авто установка в зависимости от версии и разрядности ОС
Добавление/Удаление профилей
Переменные
Несколько команд для одного пункта
Импорт в реестр до и после установки приложения
Ошибки при использовании дисков с аппаратной защитой от записи
Условные обозначения
Как переименовать группу?
Советы
Ссылки на профиль


Выбор приложений по умолчанию

При сохранении профиля, расставленные галочки сохраняются. При загрузке профиля галочки ставятся только на против тех приложений, которые не установленны. Это, что бы вручную каждый раз не снимать галочки перед установкой. Перед каждым сохранением профиля, нужно восстанавливать галочки для уже установленных приложений, для этого есть кнопка "По умолчанию". При нажатии на кнопку "По умолчанию" галочки расставятся так, как они были расставлены перед прошлым сохранением в прошлом сеансе, потом при необходимости расставьте галочки и сохраните. Что бы каждый раз не видеть предупреждения о том, что приложение уже установленно или не совместимо, предварительно перейдите в режим редактирования (для сохранения все равно туда пойдете).


Дополнительные функции в контекстном меню

Что бы открыть контекстное меню, щелкните правой кнопкой мыши по нужному приложению.


Авто установка в зависимости от версии и разрядности ОС

Делаем универсальный авто установщик с помощью моей утилиты Macros,
или любым другим вашим способом и добавляем его в MInstAll. Для разрядности есть специальная переменная.


Добавление/Удаление профилей

Для добавления нового профиля, есть специальная функция в контекстном меню.
Имена ini-файлов профилей, для удобства можно переименовывать как угодно, хранить их можно в подкаталоге Profiles,
исключение файл minst.ini, он должен быть рядом с MInst.exe т.к. он одновременно и файл настроек.


Переменные

Кроме стандартных переменных, программа поддерживает не стандартные переменные:
{Patch} - путь к папке из которой запущено приложение MInst.exe
{Root} - на папку выше {Patch}
{Disk} - буква диска, с которого запущено приложение
При добавлении приложений, переменные добавляются автоматически.
{P} - Разрядность ОС, принимает значение x86 или x64, нужно вручную заменять разрядность в путях на эту переменную, в тех случаях, когда это необходимо
{V} - Версия операционной системы


Несколько команд для одного пункта

Вариант 1:
Используйте bat-ник, в качестве текущего каталога автоматически назначается каталог где лежит bat-ник.
Вариант 2:
Выполнение целого профиля одним пунктом


  • MInstAll
  • FAQ
  • Импорт в реестр до и после установки приложения
MInstAll © 2015 Дмитрий Малгин

Импорт в реестр до и после установки приложения

Смотри описание "Несколько команд для одного пункта"


Ошибки при использовании дисков с аппаратной защитой от записи

При использовании дисков с аппаратной защитой от записи, должна быть включена опция: Главное меню -> Настройки -> "Определять защиту от записи".


  • MInstAll
  • FAQ
  • Условные обозначения
MInstAll © 2015 Дмитрий Малгин

Условные обозначения


Как переименовать группу?

Так же как переименовать файл в проводнике, два одинарных клика по группе, в редакторе групп.


Советы

• Во избежании тормозов при наличие антивируса (защитник Windows) не указывайте в качестве иконки сам exe-шник дистрибутива, используйте специальные наборы в dll-ке или отдельный файл иконки *.ico. (Файл iconapp.dll содержит довольно много иконок)
• Открыть описание программы в отдельном окне, можно кликнув средней кнопкой мыши по интересующему приложению.


Ссылки на профиль

Для добавления ссылки перехода в профиль, нужно просто добавить вместо приложения, ini-файл профиля. Подразумевается, что такие ссылки для быстрого перехода в профили (Быстрый, имеется ввиду, переход игнорируя выпадающий список с большим количеством профилей), будут добавляться в профиль с атрибутом "для запуска портативных приложений".


О ложных срабатываниях антивирусов

В моих программах нет и никогда не было вредоносного кода. Всегда были, есть и будут ложные срабатывания антивирусов, в этом нет моей вины, виноваты кривые антивирусы.
Авторские программы не защищенные именной цифровой подписью находятся в повышенной зоне риска, для антивирусов это неизвестный потенциально опасный файл, антивирус не знает какие функции выполняет программа, в связи с чем, довольно часто, как правило эвристический анализ, детектирует угрозу. Если антивирус не нашел угрозу в файле, это еще не значит, что ее там нет, антивирусы детектируют только вершину айсберга из всего вредоносного кода. Как же быть? Нужно для себя решить, доверяете вы конкретному автору или нет.
Авторитет антивирусов и их роль в жизни разработчика